What’s Vulnerable › Vulnerabilities
CVE-2022-4706: Genesis Columns Advanced < 2.0.4 - Contributor+ Stored XSS via Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-23 · updated 2026-06-17
Description
The Genesis Columns Advanced WordPress plugin before 2.0.4 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as a contributor to perform Stored Cross-Site Scripting attacks which could be used against high-privilege users such as admins.
Affected products
- Genesis Columns Advanced: before 2.0.4 — fixed in 2.0.4
How to fix
Upgrade to a fixed version: Genesis Columns Advanced 2.0.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/30882a45-ca03-4ff1-a36d-758d9b9b641c
- https://wpscan.com/vulnerability/30882a45-ca03-4ff1-a36d-758d9b9b641c
Get alerted when CVE-2022-4706 or the next vulnerability affects your stack