What’s Vulnerable › Vulnerabilities
CVE-2022-47085
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-07-18 · updated 2026-06-17
Description
An issue was discovered in ostree before 2022.7 allows attackers to cause a denial of service or other unspecified impacts via the print_panic function in repo_checkout_filter.rs.
Affected products
- Ostree Project Ostree: before 2022.7 — fixed in 2022.7
How to fix
Upgrade to a fixed version: Ostree Project Ostree 2022.7. Check the vendor advisory for mitigations.
References
- https://doc.rust-lang.org/std/macro.eprintln.html
- https://github.com/ostreedev/ostree/issues/2775
- https://doc.rust-lang.org/std/macro.eprintln.html
- https://github.com/ostreedev/ostree/issues/2775
Get alerted when CVE-2022-47085 or the next vulnerability affects your stack