What’s Vulnerable › Vulnerabilities
CVE-2022-4712: WP Cerber Security <= 9.1 - Unauthenticated Stored Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-20 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP Cerber Security plugin for WordPress is vulnerable to stored cross-site scripting via the log parameter when logging in to the site in versions up to, and including, 9.1. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- gioni WP Cerber Security, Anti-spam & Malware Scan: before 9.2 — fixed in 9.2
How to fix
Upgrade to a fixed version: gioni WP Cerber Security, Anti-spam & Malware Scan 9.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/wp-cerber/trunk/admin/cerber-dashboard.php?rev=2721561#L1338
- https://www.wordfence.com/threat-intel/vulnerabilities/id/6cd9cbba-10b0-4fb0-ad49-4593a307a615?source=cve
- https://plugins.trac.wordpress.org/browser/wp-cerber/trunk/admin/cerber-dashboard.php?rev=2721561#L1338
- https://www.wordfence.com/threat-intel/vulnerabilities/id/6cd9cbba-10b0-4fb0-ad49-4593a307a615?source=cve
Get alerted when CVE-2022-4712 or the next vulnerability affects your stack