What’s Vulnerable › Vulnerabilities
CVE-2022-4714: WP Dark Mode < 4.0.0 - Contributor+ Stored XSS in Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-21 · updated 2026-06-17
Description
The WP Dark Mode WordPress plugin before 4.0.0 does not validate and escape one of its shortcode attributes, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attack
Affected products
- WP Dark Mode: before 4.0.0 — fixed in 4.0.0
How to fix
Upgrade to a fixed version: WP Dark Mode 4.0.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/61b475f1-bbfb-4450-a3b2-b8caf5df2340
- https://wpscan.com/vulnerability/61b475f1-bbfb-4450-a3b2-b8caf5df2340
Get alerted when CVE-2022-4714 or the next vulnerability affects your stack