What’s Vulnerable › Vulnerabilities
CVE-2022-47145: WordPress Blockonomics Plugin <= 3.5.7 is vulnerable to Cross Site Scripting (XSS)
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-23 · updated 2026-06-17
- Weakness: CWE-79
Description
Reflected Cross-Site Scripting (XSS) vulnerability in Blockonomics WordPress Bitcoin Payments – Blockonomics plugin <= 3.5.7 versions.
Affected products
- Blockonomics WordPress Bitcoin Payments – Blockonomics: before 3.5.8 — fixed in 3.5.8
How to fix
Upgrade to a fixed version: Blockonomics WordPress Bitcoin Payments – Blockonomics 3.5.8. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/blockonomics-bitcoin-payments/wordpress-wordpress-bitcoin-payments-blockonomics-plugin-3-5-7-cross-site-scripting-xss?_s_id=cve
- https://patchstack.com/database/vulnerability/blockonomics-bitcoin-payments/wordpress-wordpress-bitcoin-payments-blockonomics-plugin-3-5-7-cross-site-scripting-xss?_s_id=cve
Get alerted when CVE-2022-47145 or the next vulnerability affects your stack