What’s Vulnerable › Vulnerabilities
CVE-2022-4715: Structured Content < 1.5.1 - Contributor+ Stored XSS in Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-23 · updated 2026-06-17
Description
The Structured Content WordPress plugin before 1.5.1 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.
Affected products
- Gordon Böhme, Antonio Leutsch Structured Content (JSON-LD) #wpsc: before 1.5.1 — fixed in 1.5.1
How to fix
Upgrade to a fixed version: Gordon Böhme, Antonio Leutsch Structured Content (JSON-LD) #wpsc 1.5.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/4394fe86-4240-4454-b724-81464b04123a
- https://wpscan.com/vulnerability/4394fe86-4240-4454-b724-81464b04123a
Get alerted when CVE-2022-4715 or the next vulnerability affects your stack