What’s Vulnerable › Vulnerabilities
CVE-2022-4716: WP Popups < 2.1.4.8 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-23 · updated 2026-06-17
Description
The WP Popups WordPress plugin before 2.1.4.8 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.
Affected products
- WP Popups: before 2.1.4.8 — fixed in 2.1.4.8
How to fix
Upgrade to a fixed version: WP Popups 2.1.4.8. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/24176ad3-2317-4853-b4db-8394384d52cd
- https://wpscan.com/vulnerability/24176ad3-2317-4853-b4db-8394384d52cd
Get alerted when CVE-2022-4716 or the next vulnerability affects your stack