What’s Vulnerable › Vulnerabilities
CVE-2022-4717: Strong Testimonials < 3.0.3 - Contributor+ Stored XSS via Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-06 · updated 2026-06-17
Description
The Strong Testimonials WordPress plugin before 3.0.3 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.
Affected products
- machothemes Strong Testimonials: before 3.0.3 — fixed in 3.0.3
How to fix
Upgrade to a fixed version: machothemes Strong Testimonials 3.0.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/14b679f5-44a8-46d4-89dd-94eb647cb672
- https://wpscan.com/vulnerability/14b679f5-44a8-46d4-89dd-94eb647cb672
Get alerted when CVE-2022-4717 or the next vulnerability affects your stack