What’s Vulnerable › Vulnerabilities
CVE-2022-47188: Improper Input Validation in Generex CS141
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-31 · updated 2026-06-17
- Weakness: CWE-20
Description
There is an arbitrary file reading vulnerability in Generex UPS CS141 below 2.06 version. An attacker, making use of the default credentials, could upload a backup file containing a symlink to /etc/shadow, allowing him to obtain the content of this path.
Affected products
- Generex UPS CS141: before 2.06 — fixed in 2.06
How to fix
Upgrade to a fixed version: Generex UPS CS141 2.06. Check the vendor advisory for mitigations.
References
- https://www.generex.de/support/changelogs/cs141/2-12
- https://www.generex.de/support/changelogs/cs141/page:2
- https://www.incibe-cert.es/en/early-warning/ics-advisories/update-03032023-multiple-vulnerabilities-generex-ups-cs141
- https://www.generex.de/support/changelogs/cs141/2-12
- https://www.generex.de/support/changelogs/cs141/page:2
- https://www.incibe-cert.es/en/early-warning/ics-advisories/update-03032023-multiple-vulnerabilities-generex-ups-cs141
Get alerted when CVE-2022-47188 or the next vulnerability affects your stack