What’s Vulnerable › Vulnerabilities
CVE-2022-4727: OpenMRS Appointment Scheduling Module Notes AppointmentRequest.java getNotes cross site scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-27 · updated 2026-06-17
- Weakness: CWE-707
Description
A vulnerability, which was classified as problematic, was found in OpenMRS Appointment Scheduling Module up to 1.16.x. This affects the function getNotes of the file api/src/main/java/org/openmrs/module/appointmentscheduling/AppointmentRequest.java of the component Notes Handler. The manipulation of the argument notes leads to cross site scripting. It is possible to initiate the attack remotely. Upgrading to version 1.17.0 is able to address this issue. The name of the patch is 2ccbe39c020809765de41eeb8ee4c70b5ec49cc8. It is recommended to upgrade the affected component. The identifier VDB-216741 was assigned to this vulnerability.
Affected products
- OpenMRS Appointment Scheduling Module: before 1.17.0 — fixed in 1.17.0
How to fix
Upgrade to a fixed version: OpenMRS Appointment Scheduling Module 1.17.0. Check the vendor advisory for mitigations.
References
- https://github.com/openmrs/openmrs-module-appointmentscheduling/commit/2ccbe39c020809765de41eeb8ee4c70b5ec49cc8
- https://github.com/openmrs/openmrs-module-appointmentscheduling/pull/39
- https://github.com/openmrs/openmrs-module-appointmentscheduling/releases/tag/1.17.0
- https://vuldb.com/?id.216741
- https://github.com/openmrs/openmrs-module-appointmentscheduling/commit/2ccbe39c020809765de41eeb8ee4c70b5ec49cc8
- https://github.com/openmrs/openmrs-module-appointmentscheduling/pull/39
- https://github.com/openmrs/openmrs-module-appointmentscheduling/releases/tag/1.17.0
- https://vuldb.com/?id.216741
Get alerted when CVE-2022-4727 or the next vulnerability affects your stack