What’s Vulnerable › Vulnerabilities
CVE-2022-47378: CODESYS: Multiple products prone to Improper Input Validation
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-15 · updated 2026-06-17
- Weakness: CWE-20
Description
Multiple CODESYS products in multiple versions are prone to a improper input validation vulnerability. An authenticated remote attacker may craft specific requests that use the vulnerability leading to a denial-of-service condition.
Affected products
- CODESYS Control for BeagleBone SL: before 4.8.0.0 — fixed in 4.8.0.0
- CODESYS Control For Empc-A/Imx6 Sl: before 4.8.0.0 — fixed in 4.8.0.0
- CODESYS Control for IOT2000 SL: before 4.8.0.0 — fixed in 4.8.0.0
- CODESYS Control for Linux SL: before 4.8.0.0 — fixed in 4.8.0.0
- CODESYS Control for PFC100 SL: before 4.8.0.0 — fixed in 4.8.0.0
- CODESYS Control for PFC200 SL: before 4.8.0.0 — fixed in 4.8.0.0
- CODESYS Control for PLCnext SL: before 4.8.0.0 — fixed in 4.8.0.0
- CODESYS Control for Raspberry Pi SL: before 4.8.0.0 — fixed in 4.8.0.0
- CODESYS Control for WAGO Touch Panels 600 SL: before 4.8.0.0 — fixed in 4.8.0.0
- CODESYS Control Rte (For Beckhoff Cx) Sl: before 3.5.19.0 — fixed in 3.5.19.0
- CODESYS Control Rte (Sl): before 3.5.19.0 — fixed in 3.5.19.0
- CODESYS Control Runtime System Toolkit: before 3.5.19.0 — fixed in 3.5.19.0
- CODESYS Control Win (Sl): before 3.5.19.0 — fixed in 3.5.19.0
- CODESYS Development System V3: before 3.5.19.0 — fixed in 3.5.19.0
- CODESYS Hmi (Sl): before 3.5.19.0 — fixed in 3.5.19.0
- CODESYS Safety SIL2 PSP: before 3.5.19.0 — fixed in 3.5.19.0
- CODESYS Safety SIL2 Runtime Toolkit: before 3.5.19.0 — fixed in 3.5.19.0
How to fix
Upgrade to a fixed version: CODESYS Control for BeagleBone SL 4.8.0.0; CODESYS Control For Empc-A/Imx6 Sl 4.8.0.0; CODESYS Control for IOT2000 SL 4.8.0.0; CODESYS Control for Linux SL 4.8.0.0; CODESYS Control for PFC100 SL 4.8.0.0; CODESYS Control for PFC200 SL 4.8.0.0; CODESYS Control for PLCnext SL 4.8.0.0; CODESYS Control for Raspberry Pi SL 4.8.0.0; CODESYS Control for WAGO Touch Panels 600 SL 4.8.0.0; CODESYS Control Rte (For Beckhoff Cx) Sl 3.5.19.0; CODESYS Control Rte (Sl) 3.5.19.0; CODESYS Control Runtime System Toolkit 3.5.19.0. Check the vendor advisory for mitigations.
References
- https://customers.codesys.com/index.php?eID=dumpFile&t=f&f=17554&token=5444f53b4c90fe37043671a100dffa75305d1825&download=
- https://customers.codesys.com/index.php?eID=dumpFile&t=f&f=17554&token=5444f53b4c90fe37043671a100dffa75305d1825&download=
Get alerted when CVE-2022-47378 or the next vulnerability affects your stack