What’s Vulnerable › Vulnerabilities
CVE-2022-4746: FluentAuth < 1.0.2 - Bypass blocks by IP Spoofing
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-23 · updated 2026-06-17
- Weakness: CWE-290
Description
The FluentAuth WordPress plugin before 1.0.2 prioritizes getting a visitor's IP address from certain HTTP headers over PHP's REMOTE_ADDR, which makes it possible to bypass the IP-based blocks set by the plugin.
Affected products
- FluentAuth: before 1.0.2 — fixed in 1.0.2
How to fix
Upgrade to a fixed version: FluentAuth 1.0.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/62e3babc-00c6-4a35-972f-8f03ba70ba32
- https://wpscan.com/vulnerability/62e3babc-00c6-4a35-972f-8f03ba70ba32
Get alerted when CVE-2022-4746 or the next vulnerability affects your stack