What’s Vulnerable › Vulnerabilities
CVE-2022-4747: Post Category Image With Grid and Slider < 1.4.8 - Contributor+ Stored XSS via Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-06 · updated 2026-06-17
Description
The Post Category Image With Grid and Slider WordPress plugin before 1.4.8 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.
Affected products
- Post Category Image With Grid and Slider: before 1.4.8 — fixed in 1.4.8
How to fix
Upgrade to a fixed version: Post Category Image With Grid and Slider 1.4.8. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/004f1872-1576-447f-8837-f29fa319cbdc
- https://wpscan.com/vulnerability/004f1872-1576-447f-8837-f29fa319cbdc
Get alerted when CVE-2022-4747 or the next vulnerability affects your stack