What’s Vulnerable › Vulnerabilities
CVE-2022-4749: Posts List Designer by Category < 3.2 - Contributor+ Stored XSS via Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-30 · updated 2026-06-17
- Weakness: CWE-79
Description
The Posts List Designer by Category WordPress plugin before 3.2 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.
Affected products
- Posts List Designer by Category: before 3.2 — fixed in 3.2
How to fix
Upgrade to a fixed version: Posts List Designer by Category 3.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/8afc3b2a-81e5-4b6f-8f4c-c48492843569
- https://wpscan.com/vulnerability/8afc3b2a-81e5-4b6f-8f4c-c48492843569
Get alerted when CVE-2022-4749 or the next vulnerability affects your stack