What’s Vulnerable › Vulnerabilities
CVE-2022-4751: Word Balloon < 4.19.3 - Contributor+ Stored XSS via Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-23 · updated 2026-06-17
Description
The Word Balloon WordPress plugin before 4.19.3 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.
Affected products
- Word Balloon: before 4.19.3 — fixed in 4.19.3
How to fix
Upgrade to a fixed version: Word Balloon 4.19.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/dd5cc04a-042d-402a-ab7a-96aff3d57478
- https://wpscan.com/vulnerability/dd5cc04a-042d-402a-ab7a-96aff3d57478
Get alerted when CVE-2022-4751 or the next vulnerability affects your stack