What’s Vulnerable › Vulnerabilities
CVE-2022-47516
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-12-18 · updated 2026-06-17
- Weakness: CWE-617
Description
An issue was discovered in the libsofia-sip fork in drachtio-server before 0.8.20. It allows remote attackers to cause a denial of service (daemon crash) via a crafted UDP message that leads to a failure of the libsofia-sip-ua/tport/tport.c self assertion.
Affected products
- Drachtio-Server: before 0.8.20 — fixed in 0.8.20
How to fix
Upgrade to a fixed version: Drachtio-Server 0.8.20. Check the vendor advisory for mitigations.
References
- https://github.com/davehorton/sofia-sip/commit/13b2a135287caa2d67ac6cd5155626821e25b377
- https://github.com/drachtio/drachtio-server/issues/244
- https://lists.debian.org/debian-lts-announce/2023/02/msg00028.html
- https://www.debian.org/security/2023/dsa-5410
- https://github.com/davehorton/sofia-sip/commit/13b2a135287caa2d67ac6cd5155626821e25b377
- https://github.com/drachtio/drachtio-server/issues/244
- https://lists.debian.org/debian-lts-announce/2023/02/msg00028.html
- https://www.debian.org/security/2023/dsa-5410
Get alerted when CVE-2022-47516 or the next vulnerability affects your stack