What’s Vulnerable › Vulnerabilities
CVE-2022-47517
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-12-18 · updated 2026-06-17
- Weakness: CWE-193
Description
An issue was discovered in the libsofia-sip fork in drachtio-server before 0.8.19. It allows remote attackers to cause a denial of service (daemon crash) via a crafted UDP message that causes a url_canonize2 heap-based buffer over-read because of an off-by-one error.
Affected products
- Drachtio-Server: before 0.8.19 — fixed in 0.8.19
How to fix
Upgrade to a fixed version: Drachtio-Server 0.8.19. Check the vendor advisory for mitigations.
References
- https://github.com/davehorton/sofia-sip/commit/22c1bd191f0acbf11f0c0fbea1845d9bf9dcd47e
- https://github.com/davehorton/sofia-sip/commit/bfc79d85c8f3a4798a3305fb98f5a11c11d0d29f
- https://github.com/drachtio/drachtio-server/issues/243
- https://github.com/davehorton/sofia-sip/commit/22c1bd191f0acbf11f0c0fbea1845d9bf9dcd47e
- https://github.com/davehorton/sofia-sip/commit/bfc79d85c8f3a4798a3305fb98f5a11c11d0d29f
- https://github.com/drachtio/drachtio-server/issues/243
Get alerted when CVE-2022-47517 or the next vulnerability affects your stack