What’s Vulnerable › Vulnerabilities
CVE-2022-4753: Print-O-Matic < 2.1.8 - Contributor+ Stored XSS via Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-23 · updated 2026-06-17
Description
The Print-O-Matic WordPress plugin before 2.1.8 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.
Affected products
- Print-O-Matic: before 2.1.8 — fixed in 2.1.8
How to fix
Upgrade to a fixed version: Print-O-Matic 2.1.8. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/5d72ec1f-5379-4d8e-850c-afe8b41bb126
- https://wpscan.com/vulnerability/5d72ec1f-5379-4d8e-850c-afe8b41bb126
Get alerted when CVE-2022-4753 or the next vulnerability affects your stack