What’s Vulnerable › Vulnerabilities
CVE-2022-4758: 10WebMapBuilder < 1.0.72 - Contributor+ Stored XSS via Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-23 · updated 2026-06-17
Description
The 10WebMapBuilder WordPress plugin before 1.0.72 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.
Affected products
- 10Web Map Builder for Google Maps: before 1.0.72 — fixed in 1.0.72
How to fix
Upgrade to a fixed version: 10Web Map Builder for Google Maps 1.0.72. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/c2c89234-5e9c-47c8-9827-8ab0b10fb7d6
- https://wpscan.com/vulnerability/c2c89234-5e9c-47c8-9827-8ab0b10fb7d6
Get alerted when CVE-2022-4758 or the next vulnerability affects your stack