What’s Vulnerable › Vulnerabilities
CVE-2022-47583
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-10-19 · updated 2026-06-17
- Weakness: CWE-74
Description
Terminal character injection in Mintty before 3.6.3 allows code execution via unescaped output to the terminal.
Affected products
- mintty: before 3.6.3 — fixed in 3.6.3
How to fix
Upgrade to a fixed version: mintty 3.6.3. Check the vendor advisory for mitigations.
References
- https://dgl.cx/2023/09/ansi-terminal-security#mintty
- https://github.com/mintty/mintty/releases/tag/3.6.3
- https://dgl.cx/2023/09/ansi-terminal-security#mintty
- https://github.com/mintty/mintty/releases/tag/3.6.3
Get alerted when CVE-2022-47583 or the next vulnerability affects your stack