What’s Vulnerable › Vulnerabilities
CVE-2022-4759: GigPress < 2.3.28 - Contributor+ Stored XSS via Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-13 · updated 2026-06-17
Description
The GigPress WordPress plugin before 2.3.28 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks
Affected products
- GigPress: before 2.3.28 — fixed in 2.3.28
How to fix
Upgrade to a fixed version: GigPress 2.3.28. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/63328927-5614-4fa1-8f46-46ff0c8eb959
- https://wpscan.com/vulnerability/63328927-5614-4fa1-8f46-46ff0c8eb959
Get alerted when CVE-2022-4759 or the next vulnerability affects your stack