What’s Vulnerable › Vulnerabilities
CVE-2022-4760: OneClick Chat to Order < 1.0.4.2 - Contributor+ Stored XSS via Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-23 · updated 2026-06-17
Description
The OneClick Chat to Order WordPress plugin before 1.0.4.2 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.
Affected products
- OneClick Chat to Order: before 1.0.4.2 — fixed in 1.0.4.2
How to fix
Upgrade to a fixed version: OneClick Chat to Order 1.0.4.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/ad710c22-878a-441b-9c5a-90511b913d9d
- https://wpscan.com/vulnerability/ad710c22-878a-441b-9c5a-90511b913d9d
Get alerted when CVE-2022-4760 or the next vulnerability affects your stack