What’s Vulnerable › Vulnerabilities
CVE-2022-4762: Materialis Companion < 1.3.40 - Contributor+ Stored XSS via Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-06 · updated 2026-06-17
Description
The Materialis Companion WordPress plugin before 1.3.40 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.
Affected products
- Materialis Companion: before 1.3.40 — fixed in 1.3.40
How to fix
Upgrade to a fixed version: Materialis Companion 1.3.40. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/4500566a-e5f2-40b8-a185-2bcace221b4e
- https://wpscan.com/vulnerability/4500566a-e5f2-40b8-a185-2bcace221b4e
Get alerted when CVE-2022-4762 or the next vulnerability affects your stack