What’s Vulnerable › Vulnerabilities
CVE-2022-47629
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-20 · updated 2026-06-17
- Weakness: CWE-190
Description
Libksba before 1.6.3 is prone to an integer overflow vulnerability in the CRL signature parser.
Affected products
- Debian Linux: 10.0, 11.0
- GnuPG Libksba: before 1.6.3 — fixed in 1.6.3
How to fix
Upgrade to a fixed version: GnuPG Libksba 1.6.3. Check the vendor advisory for mitigations.
References
- https://dev.gnupg.org/T6284
- https://git.gnupg.org/cgi-bin/gitweb.cgi?p=libksba.git%3Ba=commit%3Bh=f61a5ea4e0f6a80fd4b28ef0174bee77793cf070
- https://lists.debian.org/debian-lts-announce/2022/12/msg00035.html
- https://security.gentoo.org/glsa/202212-07
- https://security.netapp.com/advisory/ntap-20230316-0011/
- https://www.debian.org/security/2022/dsa-5305
- https://dev.gnupg.org/T6284
- https://git.gnupg.org/cgi-bin/gitweb.cgi?p=libksba.git%3Ba=commit%3Bh=f61a5ea4e0f6a80fd4b28ef0174bee77793cf070
- https://lists.debian.org/debian-lts-announce/2022/12/msg00035.html
- https://security.gentoo.org/glsa/202212-07
- https://security.netapp.com/advisory/ntap-20230316-0011/
- https://www.debian.org/security/2022/dsa-5305
Get alerted when CVE-2022-47629 or the next vulnerability affects your stack