What’s Vulnerable › Vulnerabilities
CVE-2022-4763: Icon Widget < 1.3.0 - Contributor+ Stored XSS via Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-30 · updated 2026-06-17
Description
The Icon Widget WordPress plugin before 1.3.0 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.
Affected products
- Icon Widget: before 1.3.0 — fixed in 1.3.0
How to fix
Upgrade to a fixed version: Icon Widget 1.3.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/2f79a87f-c994-4a1e-b455-39d7d3c5c1b5
- https://wpscan.com/vulnerability/2f79a87f-c994-4a1e-b455-39d7d3c5c1b5
Get alerted when CVE-2022-4763 or the next vulnerability affects your stack