What’s Vulnerable › Vulnerabilities
CVE-2022-4765: Portfolio for Elementor, Image Gallery & Post Grid | PowerFolio < 2.3.1 - Contributor+ Stored XSS via Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-30 · updated 2026-06-17
- Weakness: CWE-79
Description
The Portfolio for Elementor WordPress plugin before 2.3.1 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.
Affected products
- Portfolio for Elementor, Image Gallery & Post Grid | PowerFolio: before 2.3.1 — fixed in 2.3.1
How to fix
Upgrade to a fixed version: Portfolio for Elementor, Image Gallery & Post Grid | PowerFolio 2.3.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/a21dc4a3-a4f3-4619-b8a3-493a27e14ccb
- https://wpscan.com/vulnerability/a21dc4a3-a4f3-4619-b8a3-493a27e14ccb
Get alerted when CVE-2022-4765 or the next vulnerability affects your stack