What’s Vulnerable › Vulnerabilities
CVE-2022-4770: Hitachi Vantara Pentaho Business Analytics Server - Generation of Error Message Containing Sensitive Information
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-03 · updated 2026-06-17
- Weakness: CWE-209
Description
Hitachi Vantara Pentaho Business Analytics Server prior to versions 9.4.0.0 and 9.3.0.2, including 8.3.x display the full parametrized SQL query in an error message when an invalid character is used within a Pentaho Report (*.prpt).
Affected products
- Hitachi Vantara Pentaho Business Analytics Server: before 9.3.0.2 — fixed in 9.3.0.2
How to fix
Upgrade to a fixed version: Hitachi Vantara Pentaho Business Analytics Server 9.3.0.2. Check the vendor advisory for mitigations.
References
- https://support.pentaho.com/hc/en-us/articles/14455209015949--Resolved-Hitachi-Vantara-Pentaho-Business-Analytics-Server-Generation-of-Error-Message-Containing-Sensitive-Information-Versions-before-9-4-0-0-and-9-3-0-2-including-8-3-x-Impacted-CVE-2022-4770-
- https://support.pentaho.com/hc/en-us/articles/14455209015949--Resolved-Hitachi-Vantara-Pentaho-Business-Analytics-Server-Generation-of-Error-Message-Containing-Sensitive-Information-Versions-before-9-4-0-0-and-9-3-0-2-including-8-3-x-Impacted-CVE-2022-4770-
Get alerted when CVE-2022-4770 or the next vulnerability affects your stack