What’s Vulnerable › Vulnerabilities
CVE-2022-47745
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 15.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-19 · updated 2026-06-17
- Weakness: CWE-89
Description
ZenTao 16.4 to 18.0.beta1 is vulnerable to SQL injection. After logging in with any user, you can complete SQL injection by constructing a special request and sending it to function importNotice.
Affected products
- easysoft zentaopms: from 16.4 before 18.0; 18.0-beta1 — fixed in 18.0
How to fix
Upgrade to a fixed version: easysoft zentaopms 18.0. Check the vendor advisory for mitigations.
References
- https://github.com/easysoft/zentaopms/issues/106
- https://github.com/l3s10n/ZenTaoPMS_SqlInjection
- https://github.com/easysoft/zentaopms/issues/106
- https://github.com/l3s10n/ZenTaoPMS_SqlInjection
Get alerted when CVE-2022-47745 or the next vulnerability affects your stack