What’s Vulnerable › Vulnerabilities
CVE-2022-4776: CC Child Pages < 1.43 - Contributor+ Stored XSS via Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-30 · updated 2026-06-17
Description
The CC Child Pages WordPress plugin before 1.43 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.
Affected products
- caterhamcomputing CC Child Pages: before 1.43 — fixed in 1.43
How to fix
Upgrade to a fixed version: caterhamcomputing CC Child Pages 1.43. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/d5ea8f7f-7d5a-4b2e-a070-a9aef7cac58a
- https://wpscan.com/vulnerability/d5ea8f7f-7d5a-4b2e-a070-a9aef7cac58a
Get alerted when CVE-2022-4776 or the next vulnerability affects your stack