What’s Vulnerable › Vulnerabilities
CVE-2022-4787: Themify Shortcodes < 2.0.8 - Contributor+ Stored XSS via Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-30 · updated 2026-06-17
- Weakness: CWE-79
Description
Themify Shortcodes WordPress plugin before 2.0.8 does not validate and escape one of its shortcode attributes, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attack.
Affected products
- Themify Shortcodes: before 2.0.8 — fixed in 2.0.8
How to fix
Upgrade to a fixed version: Themify Shortcodes 2.0.8. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/2ab59972-ccfd-48f6-b879-58fb38823ca5
- https://wpscan.com/vulnerability/2ab59972-ccfd-48f6-b879-58fb38823ca5
Get alerted when CVE-2022-4787 or the next vulnerability affects your stack