What’s Vulnerable › Vulnerabilities
CVE-2022-4789: WPZOOM Portfolio < 1.2.2 - Contributor+ Stored XSS via Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-23 · updated 2026-06-17
Description
The WPZOOM Portfolio WordPress plugin before 1.2.2 does not validate and escape one of its shortcode attributes, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attack.
Affected products
- WPZOOM Portfolio: before 1.2.2 — fixed in 1.2.2
How to fix
Upgrade to a fixed version: WPZOOM Portfolio 1.2.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/5e816e9a-84e5-42d2-a7ff-e46be9072278
- https://wpscan.com/vulnerability/5e816e9a-84e5-42d2-a7ff-e46be9072278
Get alerted when CVE-2022-4789 or the next vulnerability affects your stack