What’s Vulnerable › Vulnerabilities
CVE-2022-47894: Apache Zeppelin SAP: connecting to a malicious SAP server allowed it to perform XXE
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-09 · updated 2026-06-17
- Weakness: CWE-20
Description
Improper Input Validation vulnerability in Apache Zeppelin SAP.This issue affects Apache Zeppelin SAP: from 0.8.0 before 0.11.0. As this project is retired, we do not plan to release a version that fixes this issue. Users are recommended to find an alternative or restrict access to the instance to trusted users. For more information, the fix already was merged in the source code but Zeppelin decided to retire the SAP component NOTE: This vulnerability only affects products that are no longer supported by the maintainer.
Affected products
- Apache Software Foundation Apache Zeppelin: from 0.8.0 before 0.11.0 — fixed in 0.11.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Zeppelin 0.11.0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2024/04/09/4
- https://github.com/apache/zeppelin/pull/4302
- https://lists.apache.org/thread/csf4k73kkn3nx58pm0p2qrylbox4fvyy
- http://www.openwall.com/lists/oss-security/2024/04/09/4
- https://github.com/apache/zeppelin/pull/4302
- https://lists.apache.org/thread/csf4k73kkn3nx58pm0p2qrylbox4fvyy
Get alerted when CVE-2022-47894 or the next vulnerability affects your stack