What’s Vulnerable › Vulnerabilities
CVE-2022-4790: WP Google My Business Auto Publish < 3.4 - Contributor+ Stored XSS via Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-23 · updated 2026-06-17
Description
The WP Google My Business Auto Publish WordPress plugin before 3.4 does not validate and escape one of its shortcode attributes, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attack.
Affected products
- WP Google My Business Auto Publish: before 3.4 — fixed in 3.4
How to fix
Upgrade to a fixed version: WP Google My Business Auto Publish 3.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/c01f9d36-955d-432c-8a09-ea9ee750f1a1
- https://wpscan.com/vulnerability/c01f9d36-955d-432c-8a09-ea9ee750f1a1
Get alerted when CVE-2022-4790 or the next vulnerability affects your stack