What’s Vulnerable › Vulnerabilities
CVE-2022-4791: Product Slider and Carousel with Category for WooCommerce < 2.8 - Contributor+ Stored XSS via Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-21 · updated 2026-06-17
Description
The Product Slider and Carousel with Category for WooCommerce WordPress plugin before 2.8 does not validate and escape one of its shortcode attributes, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attack.
Affected products
- Product Slider and Carousel with Category for WooCommerce: before 2.8 — fixed in 2.8
How to fix
Upgrade to a fixed version: Product Slider and Carousel with Category for WooCommerce 2.8. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/0a6e4c45-3f6d-4150-9546-141c2e3a1782
- https://wpscan.com/vulnerability/0a6e4c45-3f6d-4150-9546-141c2e3a1782
Get alerted when CVE-2022-4791 or the next vulnerability affects your stack