What’s Vulnerable › Vulnerabilities
CVE-2022-4792: News & Blog Designer Pack < 3.3 - Contributor+ Stored XSS via Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-30 · updated 2026-06-17
Description
The News & Blog Designer Pack WordPress plugin before 3.3 does not validate and escape one of its shortcode attributes, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attack.
Affected products
- infornweb Blog Designer Pack – Blog, Post Grid, Post Slider, Post Carousel, Category Post, News: before 3.3 — fixed in 3.3
How to fix
Upgrade to a fixed version: infornweb Blog Designer Pack – Blog, Post Grid, Post Slider, Post Carousel, Category Post, News 3.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/13304aca-0722-4bd9-b443-a5fed1ce22da
- https://wpscan.com/vulnerability/13304aca-0722-4bd9-b443-a5fed1ce22da
Get alerted when CVE-2022-4792 or the next vulnerability affects your stack