What’s Vulnerable › Vulnerabilities
CVE-2022-47924: Arbitrary Code Execution using the validate function of csaf-validator-lib
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-27 · updated 2026-10-23
- Weakness: CWE-20
Description
An high privileged attacker may pass crafted arguments to the validate function of csaf-validator-lib of a locally installed Secvisogram in versions < 0.1.0 wich can result in arbitrary code execution and DoS once the users triggers the validation.
Affected products
- Secvisogram csaf-validator-service: before 0.1.0 — fixed in 0.1.0
How to fix
Upgrade to a fixed version: Secvisogram csaf-validator-service 0.1.0. Check the vendor advisory for mitigations.
References
- https://wid.cert-bund.de/.well-known/csaf/white/2022/bsi-2022-0004.json
- https://wid.cert-bund.de/.well-known/csaf/white/2022/bsi-2022-0004.json
Get alerted when CVE-2022-47924 or the next vulnerability affects your stack