What’s Vulnerable › Vulnerabilities
CVE-2022-47925: Insufficient Input Validation in the Endpoint of the csaf-validator-service
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-27 · updated 2026-06-17
- Weakness: CWE-20
Description
The validate JSON endpoint of the Secvisogram csaf-validator-service in versions < 0.1.0 processes tests with unexpected names. This insufficient input validation of requests by an unauthenticated remote user might lead to a partial DoS of the service. Only the request of the attacker is affected by this vulnerability.
Affected products
- Secvisogram csaf-validator-service: before 0.1.0 — fixed in 0.1.0
How to fix
Upgrade to a fixed version: Secvisogram csaf-validator-service 0.1.0. Check the vendor advisory for mitigations.
References
- https://wid.cert-bund.de/.well-known/csaf/white/2022/bsi-2022-0004.json
- https://wid.cert-bund.de/.well-known/csaf/white/2022/bsi-2022-0004.json
Get alerted when CVE-2022-47925 or the next vulnerability affects your stack