What’s Vulnerable › Vulnerabilities
CVE-2022-4794: AAWP < 3.12.3 - Unsafe URL Handling
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-30 · updated 2026-06-17
Description
The AAWP WordPress plugin before 3.12.3 can be used to abuse trusted domains to load malware or other files through it (Reflected File Download) to bypass firewall rules in companies.
Affected products
- Getaawp Amazon Affiliate Wordpress Plugin: before 3.12.3 — fixed in 3.12.3
How to fix
Upgrade to a fixed version: Getaawp Amazon Affiliate Wordpress Plugin 3.12.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/feb4580d-df15-45c8-b59e-ad406e4b064c
- https://wpscan.com/vulnerability/feb4580d-df15-45c8-b59e-ad406e4b064c
Get alerted when CVE-2022-4794 or the next vulnerability affects your stack