What’s Vulnerable › Vulnerabilities

CVE-2022-47940

Description

An issue was discovered in ksmbd in the Linux kernel 5.15 through 5.18 before 5.18.18. fs/ksmbd/smb2pdu.c lacks length validation in the non-padding case in smb2_write.

Affected products

How to fix

Upgrade to a fixed version: Linux kernel 5.15.145, 5.18.18. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-47940 or the next vulnerability affects your stack