What’s Vulnerable › Vulnerabilities
CVE-2022-47950
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-18 · updated 2026-06-17
- Weakness: CWE-552
Description
An issue was discovered in OpenStack Swift before 2.28.1, 2.29.x before 2.29.2, and 2.30.0. By supplying crafted XML files, an authenticated user may coerce the S3 API into returning arbitrary file contents from the host server, resulting in unauthorized read access to potentially sensitive data. This impacts both s3api deployments (Rocky or later), and swift3 deployments (Queens and earlier, no longer actively developed).
Affected products
- Debian Linux: 10.0
- OpenStack Swift: before 2.28.1; from 2.29.0 before 2.29.2; 2.30.0 — fixed in 2.28.1, 2.29.2
How to fix
Upgrade to a fixed version: OpenStack Swift 2.28.1, 2.29.2. Check the vendor advisory for mitigations.
References
- https://launchpad.net/bugs/1998625
- https://lists.debian.org/debian-lts-announce/2023/01/msg00021.html
- https://security.openstack.org/ossa/OSSA-2023-001.html
- https://www.debian.org/security/2023/dsa-5327
- https://launchpad.net/bugs/1998625
- https://lists.debian.org/debian-lts-announce/2023/01/msg00021.html
- https://security.openstack.org/ossa/OSSA-2023-001.html
- https://www.debian.org/security/2023/dsa-5327
Get alerted when CVE-2022-47950 or the next vulnerability affects your stack