What’s Vulnerable › Vulnerabilities
CVE-2022-4801: Insufficient Granularity of Access Control in usememos/memos
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-12-28 · updated 2026-06-17
- Weakness: CWE-1220
Description
Insufficient Granularity of Access Control in GitHub repository usememos/memos prior to 0.9.1.
Affected products
- usememos/memos: before 0.9.1 — fixed in 0.9.1
How to fix
Upgrade to a fixed version: usememos/memos 0.9.1. Check the vendor advisory for mitigations.
References
- https://github.com/usememos/memos/commit/3556ae4e651d9443dc3bb8a170dd3cc726517a53
- https://huntr.dev/bounties/b0795261-0f97-4f0b-be44-9dc079e01593
- https://github.com/usememos/memos/commit/3556ae4e651d9443dc3bb8a170dd3cc726517a53
- https://huntr.dev/bounties/b0795261-0f97-4f0b-be44-9dc079e01593
Get alerted when CVE-2022-4801 or the next vulnerability affects your stack