What’s Vulnerable › Vulnerabilities
CVE-2022-48063
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-08-22 · updated 2026-06-17
- Weakness: CWE-400
Description
GNU Binutils before 2.40 was discovered to contain an excessive memory consumption vulnerability via the function load_separate_debug_files at dwarf2.c. The attacker could supply a crafted ELF file and cause a DNS attack.
Affected products
- GNU Binutils: before 2.40 — fixed in 2.40
How to fix
Upgrade to a fixed version: GNU Binutils 2.40. Check the vendor advisory for mitigations.
References
- https://security.netapp.com/advisory/ntap-20231006-0008/
- https://sourceware.org/bugzilla/show_bug.cgi?id=29924
- https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git%3Bh=75393a2d54bcc40053e5262a3de9d70c5ebfbbfd
- https://security.netapp.com/advisory/ntap-20231006-0008/
- https://sourceware.org/bugzilla/show_bug.cgi?id=29924
- https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git%3Bh=75393a2d54bcc40053e5262a3de9d70c5ebfbbfd
Get alerted when CVE-2022-48063 or the next vulnerability affects your stack