What’s Vulnerable › Vulnerabilities
CVE-2022-4824: WP Blog and Widget < 2.3.1 - Contributor+ Stored XSS via Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-06 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP Blog and Widgets WordPress plugin before 2.3.1 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.
Affected products
- WP Blog and Widgets: before 2.3.1 — fixed in 2.3.1
How to fix
Upgrade to a fixed version: WP Blog and Widgets 2.3.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/9af8e425-c477-4e2b-9445-70ffb769f3f0
- https://wpscan.com/vulnerability/9af8e425-c477-4e2b-9445-70ffb769f3f0
Get alerted when CVE-2022-4824 or the next vulnerability affects your stack