What’s Vulnerable › Vulnerabilities
CVE-2022-4825: WP-ShowHide < 1.05 - Contributor+ Stored XSS via Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-06 · updated 2026-06-17
Description
The WP-ShowHide WordPress plugin before 1.05 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.
Affected products
- WP-ShowHide: before 1.05 — fixed in 1.05
How to fix
Upgrade to a fixed version: WP-ShowHide 1.05. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/a2758983-d3a7-4718-b5b8-30169df6780a
- https://wpscan.com/vulnerability/a2758983-d3a7-4718-b5b8-30169df6780a
Get alerted when CVE-2022-4825 or the next vulnerability affects your stack