What’s Vulnerable › Vulnerabilities
CVE-2022-48279
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-20 · updated 2026-06-17
- Weakness: CWE-436
Description
In ModSecurity before 2.9.6 and 3.x before 3.0.8, HTTP multipart requests were incorrectly parsed and could bypass the Web Application Firewall. NOTE: this is related to CVE-2022-39956 but can be considered independent changes to the ModSecurity (C language) codebase.
Affected products
- Debian Linux: 10.0
- owasp-modsecurity ModSecurity: from 3.0.0 before 3.0.8 — fixed in 3.0.8
- Trustwave Modsecurity: before 2.9.6 — fixed in 2.9.6
How to fix
Upgrade to a fixed version: owasp-modsecurity ModSecurity 3.0.8; Trustwave Modsecurity 2.9.6. Check the vendor advisory for mitigations.
References
- https://coreruleset.org/20220919/crs-version-3-3-3-and-3-2-2-covering-several-cves/
- https://github.com/SpiderLabs/ModSecurity/pull/2795
- https://github.com/SpiderLabs/ModSecurity/pull/2797
- https://github.com/SpiderLabs/ModSecurity/releases/tag/v2.9.6
- https://github.com/SpiderLabs/ModSecurity/releases/tag/v3.0.8
- https://lists.debian.org/debian-lts-announce/2023/01/msg00023.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/52TGCZCOHYBDCVWJYNN2PS4QLOHCXWTQ/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/SYRTXTOQQI6SB2TLI5QXU76DURSLS4XI/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/WCH6JM4I4MD4YABYFHSBDDOUFDGIFJKL/
- https://coreruleset.org/20220919/crs-version-3-3-3-and-3-2-2-covering-several-cves/
- https://github.com/SpiderLabs/ModSecurity/pull/2795
- https://github.com/SpiderLabs/ModSecurity/pull/2797
Get alerted when CVE-2022-48279 or the next vulnerability affects your stack