What’s Vulnerable › Vulnerabilities
CVE-2022-4828: Bold Timeline Lite < 1.1.5 - Contributor+ Stored XSS via Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-30 · updated 2026-06-17
Description
The Bold Timeline Lite WordPress plugin before 1.1.5 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.
Affected products
- boldthemes Bold Timeline Lite: before 1.1.5 — fixed in 1.1.5
How to fix
Upgrade to a fixed version: boldthemes Bold Timeline Lite 1.1.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/06e1d63e-576b-4e16-beb7-4f0bfb85e948
- https://wpscan.com/vulnerability/06e1d63e-576b-4e16-beb7-4f0bfb85e948
Get alerted when CVE-2022-4828 or the next vulnerability affects your stack