What’s Vulnerable › Vulnerabilities
CVE-2022-4830: Paid Memberships Pro < 2.9.9 - Contributor+ Stored XSS via Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 65.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The Paid Memberships Pro WordPress plugin before 2.9.9 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.
Affected products
- Paid Memberships Pro: before 2.9.9 — fixed in 2.9.9
How to fix
Upgrade to a fixed version: Paid Memberships Pro 2.9.9. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/ae103336-a411-4ebf-a5f0-2f35701e364c
- https://wpscan.com/vulnerability/ae103336-a411-4ebf-a5f0-2f35701e364c
Get alerted when CVE-2022-4830 or the next vulnerability affects your stack