What’s Vulnerable › Vulnerabilities
CVE-2022-48306: Gotham Chat IRC help does not validate hostnames in TLS certificates
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-16 · updated 2026-06-17
- Weakness: CWE-297
Description
Improper Validation of Certificate with Host Mismatch vulnerability in Gotham Chat IRC helper of Palantir Gotham allows A malicious attacker in a privileged network position could abuse this to perform a man-in-the-middle attack. A successful man-in-the-middle attack would allow them to intercept, read, or modify network communications to and from the affected service. This issue affects: Palantir Palantir Gotham Chat IRC helper versions prior to 30221005.210011.9242.
Affected products
- Palantir Gotham Chat IRC helper: before 30221005.210011.9242 — fixed in 30221005.210011.9242
How to fix
Upgrade to a fixed version: Palantir Gotham Chat IRC helper 30221005.210011.9242. Check the vendor advisory for mitigations.
References
- https://github.com/palantir/security-bulletins/blob/main/PLTRSEC-2022-09.md
- https://github.com/palantir/security-bulletins/blob/main/PLTRSEC-2022-09.md
Get alerted when CVE-2022-48306 or the next vulnerability affects your stack