What’s Vulnerable › Vulnerabilities
CVE-2022-4832: Store Locator WordPress < 1.4.9 - Contributor+ Stored XSS via Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-23 · updated 2026-06-17
Description
The Store Locator WordPress plugin before 1.4.9 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.
Affected products
- Store Locator WordPress: before 1.4.9 — fixed in 1.4.9
How to fix
Upgrade to a fixed version: Store Locator WordPress 1.4.9. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/735a33e1-63fb-4f17-812c-3e68709b5c2c
- https://wpscan.com/vulnerability/735a33e1-63fb-4f17-812c-3e68709b5c2c
Get alerted when CVE-2022-4832 or the next vulnerability affects your stack