What’s Vulnerable › Vulnerabilities
CVE-2022-48322
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-13 · updated 2026-06-17
- Weakness: CWE-787
Description
NETGEAR Nighthawk WiFi Mesh systems and routers are affected by a stack-based buffer overflow vulnerability. This affects MR60 before 1.1.7.132, MS60 before 1.1.7.132, R6900P before 1.3.3.154, R7000P before 1.3.3.154, R7960P before 1.4.4.94, and R8000P before 1.4.4.94.
Affected products
- NETGEAR Mr60 Firmware: before 1.1.7.132 — fixed in 1.1.7.132
- NETGEAR Ms60 Firmware: before 1.1.7.132 — fixed in 1.1.7.132
- NETGEAR R6900P Firmware: before 1.3.3.154 — fixed in 1.3.3.154
- NETGEAR R7000P: before 1.3.3.154 — fixed in 1.3.3.154
- NETGEAR R7960P Firmware: before 1.4.4.94 — fixed in 1.4.4.94
- NETGEAR R8000P Firmware: before 1.4.4.94 — fixed in 1.4.4.94
How to fix
Upgrade to a fixed version: NETGEAR Mr60 Firmware 1.1.7.132; NETGEAR Ms60 Firmware 1.1.7.132; NETGEAR R6900P Firmware 1.3.3.154; NETGEAR R7000P 1.3.3.154; NETGEAR R7960P Firmware 1.4.4.94; NETGEAR R8000P Firmware 1.4.4.94. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000065265/Security-Advisory-for-Pre-authentication-Buffer-Overflow-on-Multiple-Products-PSV-2022-0155
- https://kb.netgear.com/000065265/Security-Advisory-for-Pre-authentication-Buffer-Overflow-on-Multiple-Products-PSV-2022-0155
Get alerted when CVE-2022-48322 or the next vulnerability affects your stack